My ZTE Blade running Android Jelly Bean 4.1.2 :)

Yesterday i have upgraded my ZTE Blade phone from Android 2.3.3 (yes i have rooted my phone) to … Android Jelly Bean 4.1.2.

At the beginning I wanted to upgrade my phone to ICS (Ice Cream Sandwich) 4.0.4 using different mods but… there was always something that was missing – Google Play, WiFi, connection to Google Account. Moreover the GAPPS which were prepared to be used with proper mod did not want to work… I was successful with upgrade to Android 2.3.7 using the Cyanogemod 7.2 for ZTE Blade, but…. I wanted ICS 4.0.4 !

Googling the internet was very successful – I have discovered many informations how to upgrade my ZTE Blade to ICS 4.0.4 but as I mentioned before it was not working good – I mean it was working but I was unhappy that there were problems.

So I decided to give a shot a Jelly Bean 4.1.2. From a zteblade.eu I have downloaded the CM10 – JellyBean – file was: CM-10-20121124-konstakang-blade-zip and GApps for JellyBean. First, I had to do some modyfications to my ZTE Blade – change system from GEN1 to GEN2, after that there were no problem with upgrading to JB 4.1.2.

Now I am enjoying my ZTE Blade CM10 JB 4.1.2 phone 🙂

19 Comments

  1. Jellybean 4.1.2 on ZTE Blade is wonderful… Love everything about it, migrating from Swedish Snow RLS7 2.3.5. So far so good.

    1. Nash,
      you have to do it like you did the installation of your mod:
      1. reboot to recovery
      2. select “install zip from sdcard”
      3. select “choose zip from sdcard”
      4. select gapps and install it 🙂

  2. hey thanxs, jellybean 4.1.2 is awesome on my ZTE Blade, i have really started loving my ZTE again, once again bundle of thanx

  3. hey i installed jellybean 4.1.2 on my zte blade, everthing is fine except the browser, when i open the browser it closes on its own after a minute or two, i cant install any app etc anything, somebody please guide me, thanx

  4. Pleaso someone who already have this version of android on blade III , write step by step how to instal it, my version of android is 4.0.4

  5. Hi, does anyone know why the google play app is not shown on zte blade phone 🙁 when installing the jellybean and gaap. I appreciate the help. Thanks 🙂

  6. hai..,
    my mobile Zte blade
    version 2.2.2 ..,
    can i have chance to upgrade my mobile to jelly bean..,?
    if so can anybody,please tell me the detail steps to upgrade n the needed software i need to download and install….,

    thanks in advance..

  7. sir,
    my mobile details(zte blade 2.2.2,gen2,china product)
    i downloaded that both softwares cm..,n gapps..
    After opening rom manager i entered into “reboot with recovery mode”

    able to wipe data but i am not able to get these below steps in my mobile..

    select “install zip from sdcard”
    select “choose zip from sdcard”
    select gapps and install it

    what is the problem i had,why i am unable to select the zip files from sd card n install it..,
    please help me to solve this issue..,

      1. Hello Guys, please i need guide on how to root and upgrade my ZTE V889M from 4.0.4 to 4.1.2

        I would appreciate you guys feedback. Thanks.

  8. wow..,thanku boss,
    i m now able to use jelly bean on my zte blade mobile..,
    but i lost few mobile given apps(inbuilt) like opera mini,task manager,twitter,facebook,videos,youtube,docs to go,google search,idea tv ,maps,playstore..
    i installed needed gapps to get play store back..,i am able to get dat playstore app but when i am trying to download apps from it like whatapps,viber etc..,showing some error number..

    and also have problems with browser opening but closing after 2 or 3 minutes…,

    please help me sort out these problems..,
    how to restore all the system applications on to jelly bean version,n installing apps from play store..

    thanking u for the help ..:)

  9. I have Successfully update my ZTE blade from 2.3.5 to 4.1.2 but
    Google Play is crashing after installing Custom Rom
    please tell me how to fix it.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">

This website stores some user agent data. These data are used to provide a more personalized experience and to track your whereabouts around our website in compliance with the European General Data Protection Regulation. If you decide to opt-out of any future tracking, a cookie will be set up in your browser to remember this choice for one year. I Agree, Deny
606